Aller au contenu

Grosse prise de tête avec Monsieur Excel


mathieu
 Partager

Messages recommandés

Bonjour à tous,

 

Après un combat long et fastidieux avec ce fameux excel j'ai abandonné et cherche une âme charitable pour m'aider !

 

- Problèmatique : interdire les doublons dans une liste de code (tableur pour répertorier tout les devis de notre boite)

 

- Chose que je ne comprend pas, la formule ci-dessous marchait jusqu'à la ligne 459 :

(validation des données -> personnalisé)

=NB.SI($A$149:$A$459;A4)=1

 

Je veux que cette règle s'applique de la cellule A4 à la cellule 1432, j'ai donc suivis la procédure suivante :

1 Je selectionne les cellule A4 à A1432

2 Je vais dans validations des données

3 Je choisi personnalisé

4 Je tappe la formule ci-dessous

=NB.SI($A$4:$A$1432;A4)=1 (même que celle qui marchait mais agrandis de A4 à A1432)

5 Je clique sur alerte d'erreur je choisi arrêt et mes le code personnalisé suivant "Ce nom figure déjà dans la liste"

 

et LA rien ne marche, le code ne fonctionne nul part

Chose étrange, je me met sur la cellule A100 (au hasard) je vais dans validation des données et j'ai la formule suivante lié à la cellule :

=NB.SI($A$4:$A$1432;A1047248)=1

 

WTF pourquoi j'ai la cellule A1047248 qui est là? Donc forcement ça peux pas marcher...

 

Edit : J'ai une version 2015 et 2016 du tableur, je fait exactement la même manipulation sur les deux, sur le 2016 ça marche parfaitement, sur le 2015 j'ai le problème ci dessous....

 

 

Au secours j'en peux plus !!!!!!

Modifié par mathieu
Lien vers le commentaire
Partager sur d’autres sites

Coucou

 

Tu peux essayer une autre méthode plutôt que de sélectionner tes cellules dans lesquelles tu souhaites cette validation en entrant directement dans la définition dans la case dialogue, celle que j'ai surligné en jaune sur l'image.

02-12-2015 10-33-05.gif

Amicalement

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement
 Partager

×
×
  • Créer...