Aller au contenu

serge77

Membres
  • Compteur de contenus

    136
  • Inscription

  • Dernière visite

Réputation sur la communauté

0 Neutral

À propos de serge77

  • Rang
    ceinture bleue
  • Date de naissance 19.03.1972

Profile Information

  • Gender
    Male
  • Location
    77600
  1. J'ai trouvé, Encore une histoire de \ avant les guillemets. Merci Merci Bonuscad, J'avais pas vu ton poste, du coup j'ai cherché et trouvé, ça marche très bien. Je vais gagner deux jours de boulot de m.... Cool Merci, ce bout de programme va me resservir à coup sur.
  2. Oups, J'ai inversé nouveau texte et ancien texte, ça marche nickel, merci, merci, merci. Petite question subsidiaire, vu que ce n'est pas une fonction, qu'est ce que je dois écrire pour construire un script Ex: (write-line "(my_replace_text "E318" "D214")" fscr) Ca, ça marche pour les commande, pas pour les fonctions. D'avance merci.
  3. Rebonjour, la commande (load "my_replace") me retourne Mais pas grave, je l'ai chargée au démarrage. Par contre, la fonction (my_replace_text "A315-555-xxx" "B478-555-xxx") ne me renvoi pas d'erreur mais ne fait rien. J'ai pourtant inscrit le texte dans du texte, dans des attributs, en espace papier et en espace objet pour voir...rien n'y fait.
  4. Merci pour cette réponse, j'avais pas compris la manière de l'utiliser. J'essaie de suite.
  5. Bonjour Bonuscad, Je vais passer pour un débile mais à te lire, ton code est exactement ce que je recherche. Sauf que quand je le lance, autocad me répond "commande inconnue".... Comment ça se fait ??? Qu'est ce que je dois faire ??? Ce programme serait vraiment d'une grande aide, mon client s'est trompé dans la liasse de numéro à prendre et bien sur c'est à moi de corriger donc j'ai un numéro genre "A315-555-xxx" a changer en "B478-555-xxx" sur 300 plans... Merci d'avance
  6. Effectivement je n'avais pas mis le fichier DCL au bon endroit
  7. Le lisp RB de Patrick me va très bien, je vais réussir à me débrouiller avec. Merci
  8. Merci pour ta réponse, je viens de regarder justement le edit_bloc de gile qui a l'air de faire ce que je veux mais il ne fonctionne pas chez moi. Pas de message d'erreur, juste....rien.
  9. Bonjour à tous, Tout est dans le titre, j'ai 700 plan à modifier, ranger chaque élément dans le bon calque, ça j'y arrive et les blocs se rangent dans les bons caclques mais j'aimerai aussi que les entités à l'intérieur des blocs se rangent dans les calques ou alors traiter tous les éléments à l'intérieur des bloc pour qu'il aille dans le calque 0 ou dubloc. J'espère avoir été clair, en me relisant je ne comprends presque plus ma question <_< Merci d'avance pour vos réponses
  10. Petite question subsidiaire. J'ai dans mes blocs des attributs avec dans l'étiquette des minuscules et des accents, comment est-ce possible ? Parce que lors de la mise à jour les nouvelles étiquettes transforment en majuscules sans accent et donc quand je veux synchroniser, je perds tout.... Quelqu'un pour m'en dire un peu plus, je sèche ? Merci d'avance.
  11. Je suis trop bête mais je l'avais dit.... J'ai essayer les guillemets sur le nom, sur le chemin mais pas sur l'expression entière. ^C^Czoom;e;0.00001xp;-inserer;FOND A0=c:/FOND A0.dwg;0,0;1;1;0;effacer;d;; ^C^Czoom;e;0.00001xp;-inserer;"FOND A0=c:/FOND A0.dwg";0,0;1;1;0;effacer;d;; Ca marche nickel. Merci à vous
  12. Merci pour vos conseils, je fais ça quand je travail avec mes blocs mais là, je les récupère d'un client Allemand alors je me vois mal leur répondre ça. Personne pour me dire par quoi remplacer les espace ???? Je sais qu'on peut le faire mais ne sais plus comment faire. Merci.
  13. ^C^Czoom;e;0.00001xp;-inserer;FOND A0=c:/FOND A0.dwg;0,0;1;1;0;effacer;d;; Voilà sans guillemet ou autre.... Si quelqu'un peut me corriger....
  14. c'est un truc dans le genre mais un guillemet est reconnu comme un guillemet alors il faut en mettre deux ou quelque chose comme ça, bref je ne sais plus...
×
×
  • Créer...