CADxp: Clic milieu souris dans les mapkeys - CADxp

Aller au contenu

Page 1 sur 1
  • Vous ne pouvez pas commencer un sujet
  • Vous ne pouvez pas répondre à ce sujet

Clic milieu souris dans les mapkeys

#1 L'utilisateur est hors-ligne   DCT 

  • ceinture blanche
  • Groupe : Membres
  • Messages : 2
  • Inscrit(e) : 21-décembre 17

Posté 21 décembre 2017 - 15:05

Bonjour,

dans Creo3 j'ai créé une macro permettant de mettre un symbol automatiquement dans une mise en plan.
Quand on place un symbole dans une mise en plan, on doit cliquer sur le bouton milieu de la souris pour pouvoir cliquer sur "OK" de la boite de dialogue des symboles.
Le pb est que la macro n'enregistre pas le "clic milieu". Donc quand je l'execute, la macro ne se termine pas.

mapkey dup @MAPKEY_LABELdup;\
mapkey(continued) ~ Activate `main_dlg_cur` `page_Annotate_control_btn` 1;\
mapkey(continued) ~ Command `ProCmdDwgCrSymInstCust` ;\
mapkey(continued) ~ Trail `UI Desktop` `UI Desktop` `DLG_PREVIEW_POST` `file_open`;\
mapkey(continued) ~ Select `file_open` `Ph_list.Filelist` 1 `csys_piping_iso.sym`;\
mapkey(continued) ~ Command `ProFileSelPushOpen_Standard@context_dlg_open_cmd` ;\
mapkey(continued) ~ Select `main_dlg_cur` `PHTLeft.AssyTree` 1 `node23`;\
mapkey(continued) ~ Activate `drawing_sym` `OK_push`;


J'ai tenté de récupérer les lignes correspondant au clic milieu dans le fichier trail mais je n'arrive à rien.
Au mieux, le système me prend bien le clic mais ne le relâche pas. C'est comme si on gardait le bouton milieu enfoncé.

~ MButtonArm `main_dlg_cur` `proe_win` 9 1439 512 0 2 1536 902 1920 1200 73284
~ MButtonDisarm `main_dlg_cur` `proe_win` 9 1439 512 0 0 1536 902 1920 1200 73489


Est-ce que quelqu'un aurait une idée lumineuse?

Merci.
0

#2 L'utilisateur est hors-ligne   MAX_Mafel 

  • ceinture verte
  • Groupe : Membres
  • Messages : 55
  • Inscrit(e) : 26-mars 09

Posté 02 janvier 2018 - 12:42

Bonjour,

Pour éviter ce problème, il faut modifier le type de placement, à l'origine il est "libre", et mettre "Coordonnées absolues", et mettre une valeur en X, et Y.
Je fonctionne de cette manière pour l'intégration de tables, et symbole.
0

#3 L'utilisateur est hors-ligne   DCT 

  • ceinture blanche
  • Groupe : Membres
  • Messages : 2
  • Inscrit(e) : 21-décembre 17

Posté 05 janvier 2018 - 08:47

Voir le messageMAX_Mafel, le 02 janvier 2018 - 12:42 , dit :

Bonjour,

Pour éviter ce problème, il faut modifier le type de placement, à l'origine il est "libre", et mettre "Coordonnées absolues", et mettre une valeur en X, et Y.
Je fonctionne de cette manière pour l'intégration de tables, et symbole.


Bonjour,
Je n'utilise pas de placement libre mais un placement sur entité en sélectionnant un Csys dans l'arbre du modèle 3D.
Ce qui est vraiment agaçant, c'est qu'on n'avait pas ce problème dans les anciennes versions de ProE.
0

Partager ce sujet :


Page 1 sur 1
  • Vous ne pouvez pas commencer un sujet
  • Vous ne pouvez pas répondre à ce sujet

1 utilisateur(s) en train de lire ce sujet
0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)