CADxp: Grosse prise de tête avec Monsieur Excel - CADxp

Aller au contenu

Page 1 sur 1
  • Vous ne pouvez pas commencer un sujet
  • Vous ne pouvez pas répondre à ce sujet

Grosse prise de tête avec Monsieur Excel HELLLLLLLP

#1 L'utilisateur est hors-ligne   mathieu 

  • ceinture bleue
  • Groupe : Membres
  • Messages : 165
  • Inscrit(e) : 21-novembre 12

Posté 02 décembre 2015 - 09:37

Bonjour à tous,

Après un combat long et fastidieux avec ce fameux excel j'ai abandonné et cherche une âme charitable pour m'aider !

- Problèmatique : interdire les doublons dans une liste de code (tableur pour répertorier tout les devis de notre boite)

- Chose que je ne comprend pas, la formule ci-dessous marchait jusqu'à la ligne 459 :
(validation des données -> personnalisé)
=NB.SI($A$149:$A$459;A4)=1

Je veux que cette règle s'applique de la cellule A4 à la cellule 1432, j'ai donc suivis la procédure suivante :
1 Je selectionne les cellule A4 à A1432
2 Je vais dans validations des données
3 Je choisi personnalisé
4 Je tappe la formule ci-dessous
=NB.SI($A$4:$A$1432;A4)=1 (même que celle qui marchait mais agrandis de A4 à A1432)
5 Je clique sur alerte d'erreur je choisi arrêt et mes le code personnalisé suivant "Ce nom figure déjà dans la liste"

et LA rien ne marche, le code ne fonctionne nul part
Chose étrange, je me met sur la cellule A100 (au hasard) je vais dans validation des données et j'ai la formule suivante lié à la cellule :
=NB.SI($A$4:$A$1432;A1047248)=1

WTF pourquoi j'ai la cellule A1047248 qui est là? Donc forcement ça peux pas marcher...

Edit : J'ai une version 2015 et 2016 du tableur, je fait exactement la même manipulation sur les deux, sur le 2016 ça marche parfaitement, sur le 2015 j'ai le problème ci dessous....


Au secours j'en peux plus !!!!!!

Ce message a été modifié par mathieu - 02 décembre 2015 - 10:32 .

0

#2 L'utilisateur est hors-ligne   didier 

  • ceinture rouge et blanche 8em dan
  • Groupe : Moderateurs
  • Messages : 8352
  • Inscrit(e) : 18-décembre 02
  • LocationPlanète : Terre

Posté 02 décembre 2015 - 10:40

Coucou

Tu peux essayer une autre méthode plutôt que de sélectionner tes cellules dans lesquelles tu souhaites cette validation en entrant directement dans la définition dans la case dialogue, celle que j'ai surligné en jaune sur l'image.

Fichier joint  02-12-2015 10-33-05.gif (15,61 Ko)
Nombre de téléchargements : 30
Amicalement
Éternel débutant ...
Programmer AutoCAD
0

Partager ce sujet :


Page 1 sur 1
  • Vous ne pouvez pas commencer un sujet
  • Vous ne pouvez pas répondre à ce sujet

1 utilisateur(s) en train de lire ce sujet
0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)